[Idle-dev] [ idlefork-Bugs-824595 ] filename .idlerc crashes windows98

SourceForge.net noreply at sourceforge.net
Fri Oct 17 21:11:32 EDT 2003


Bugs item #824595, was opened at 2003-10-16 01:33
Message generated for change (Comment added) made by kbk
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=109579&aid=824595&group_id=9579

Category: None
Group: None
Status: Open
Resolution: Works For Me
Priority: 1
Submitted By: Nobody/Anonymous (nobody)
Assigned to: Nobody/Anonymous (nobody)
Summary: filename .idlerc crashes windows98

Initial Comment:
Windows 98 crashes in horrible ways when filenames 
start with a dot. Even deleting the file is difficult! 
Crashes take place at totally unexpected moments, 
without any idle activity. Apparently the filesystem 
crashes when it gives the wrong interpretation to the 
starting dot.

The file .idlerc should be renamed in something without a 
dot, for instance typical windows would be idle.ini
Any name without a starting dot is OK.

----------------------------------------------------------------------

>Comment By: Kurt B. Kaiser (kbk)
Date: 2003-10-17 20:11

Message:
Logged In: YES 
user_id=149084

Duplocate of #678343 originally submitted 31Jan2003.
Cllosed as 'works for me' on 05Sep2003.
I have also been using IDLE and IDLEfork on W98 without
problems.  It's unlikely that a crash when not accessing
the file system can be caused by a filename.  Are you the
same person who submitted the previous bug?

----------------------------------------------------------------------

Comment By: Guido van Rossum (gvanrossum)
Date: 2003-10-16 10:09

Message:
Logged In: YES 
user_id=6380

We need to know more about how your system was configured.
Do you have a network filesystem or something like that?
Virus scanner tools installed?

I'm asking because I have used IDLE with this file without
trouble for years on my own win98 box, so I doubt that it's
win98 itself that causes the crashes. Filenames of this form
have always been legal in win98. But some other software
you've installed may be buggy.

----------------------------------------------------------------------

Comment By: Nobody/Anonymous (nobody)
Date: 2003-10-16 01:33

Message:
Logged In: NO 

e-mail address of submitter: gerrit.muller at embeddedsystems.nl

----------------------------------------------------------------------

You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=109579&aid=824595&group_id=9579



More information about the IDLE-dev mailing list