[Idle-dev] idle 1.0.2 cannot bind (again) to port 8833 w/python 2.3.3

Kurt B. Kaiser kbk at shore.net
Wed Feb 25 16:04:31 EST 2004

Al Schapira <a.d.schapira at worldnet.att.net> writes:

> I downloaded and installed python 2.3.3 source, built, and installed
> it with idle 1.0.2 under RH linux 9 w/kernel 2.4.20-28.9.
> The first time I ran idle, it worked fine, and I selected the default
> fonts, etc.  Subsequently, idle won't start in subproces mode.  I get
> the error output below every time.  Using -n as suggested works ok.
> How do I clear the port in use?
> How do I prevent this from happening again?

Make sure that there is only one instance of the IDLE GUI running on
your system.  The current design can only support one, though there
are plans to change that in the future.  I want to be sure that IDLE
is robust with one instance, especially on Windows, before I add more

On Linux or the BSDs, if you do  

     ps aux

you should see no python processes when IDLE isn't running, and two
when it is.  (On Windows, you'll see three.)  Kill any extra ones and
try again:

     kill -KILL xxxx

where xxxx is the pid of the python process.

Let me know if you have further problems.  Save any error messages and
a    ps aux   trace.

More information about the IDLE-dev mailing list