[Idle-dev] error with IDLE on debian

altern altern2 at gmail.com
Tue Dec 26 13:38:38 CET 2006


Hi, I wrote with this problem to the general Python mailing list but I 
did not get any answer so I decided to email to the IDLE-dev list. My 
problem is that when i try to run IDLE on my debian laptop I get this error.

$ idle
Traceback (most recent call last):
   File "/usr/bin/idle", line 5, in ?
   File "idlelib/PyShell.py", line 1359, in main
   File "idlelib/FileList.py", line 44, in new
   File "idlelib/PyShell.py", line 105, in __init__
   File "idlelib/EditorWindow.py", line 111, in __init__
   File "/usr/lib/python2.4/lib-tk/Tkinter.py", line 2764, in __init__
     Widget.__init__(self, master, 'text', cnf, kw)
   File "/usr/lib/python2.4/lib-tk/Tkinter.py", line 1865, in __init__
_tkinter.TclError: expected integer but got "`100"

Few weeks ago IDLE worked fine, I dont really know what could be causing 
the error.

I am running Debian unstable with python 2.4.4, tcl8.4, tk8.4, python-tk
24.4-1 and IDLE 2.4.4-2. I already tried to reinstall IDLE, tk and tcl
and python-tk but that did not solve anything, i keep getting the same

any ideas?



More information about the IDLE-dev mailing list