[Idle-dev] Help needed for using IDLE under Ubuntu 8.04

Bruce Sherwood Bruce_Sherwood at ncsu.edu
Sat Jun 21 06:10:01 CEST 2008

I'm also running Ubuntu 8 with Python 2.5, and I don't see any of the
misbehavior that you see.

However, it's possible that I don't understand your comment, "Python
interactive session works OK as expected. It seems that only IDLE
doesn't like RETURN to be hit after the tailing "()" of functions."
First you say it works OK, then you say it doesn't work OK.

I have no idea what's wrong on your machine, but in the IDLE shell
window I can definitely execute the function calls that you are unable
to execute.

Bruce Sherwood

叶 峰|Crow Yeh(Ye Feng) wrote:
> Hi,
> I'm totally a beginner of python. I met some strange problem on using IDLE.
> Python version is 2.5.2
> IDLE version is 1.2.2
> Ubuntu version: 8.04
> All works fine except function invoking.
> Say, the basic help() function, if I type in help(dir) and hit RETURN,
> nothing happens, and the keyboard seems to be locked inside IDLE. I mean
> no matter what I type afterwards, it looks like I typed nothing. The
> pointer keeps flickering and IDLE just refuses to accept any further
> keyboard input. The keyboard still functions well outside IDLE.
> To see the feedback of help(dir), I have to invoke File->Print Window
> (Yes the mouse still works fine inside IDLE), then I see the pointer
> moves to the beginning of the next line, and now if I hit RETURN again,
> it prints out the help info for "dir", and then my keyboard seems alive
> inside IDLE again!
> Python interactive session works OK as expected. It seems that only IDLE
> doesn't like RETURN to be hit after the tailing "()" of functions. I've
> tried several different function calls, same issue happens every time I
> hit RETURN after typing in the function call (like
> "somefunction(whatever)").
> I've tried IDLE under Windows too, works fine. Ubuntu is main OS for me
> to work on, and I don't want to switch to Windows for such a reason.
> I've tried reinstalling IDLE with no luck. I also tried asking for help
> in Ubuntu community like ubuntuforums.org, but all I get is suggestions
> of trying out other python compatible IDEs insted of how to solve the
> problem. And I get no confirm about the issue. So I don't even know if
> it is some problem happens to me only.
> Really strange, isn't it? Or am I missing something?
> Please help. I'd really like to use IDLE as python IDE as I thought it
> should be more native to python!

More information about the IDLE-dev mailing list