[Idle-dev] Configuring IDLE for Python 3.2.2 on Ubuntu

Tal Einat taleinat at gmail.com
Mon Oct 17 17:46:58 CEST 2011


On Mon, Oct 17, 2011 at 5:06 AM, Ned Deily <nad at acm.org> wrote:

> In article <32655998.post at talk.nabble.com>,
>  MusicKev <kevin at kevinturnercareer.com> wrote:
> > Ned Deily wrote:
> > > In article <32642225.post at talk.nabble.com>,
> > >  MusicKev <kevin at kevinturnercareer.com> wrote:
> > >
> > >> I have Python 2.7 and python 3.2.2 installed on my system. There is a
> > >> version
> > >> of IDLE installed for each version of Python but they all open Python
> > >> 2.7.
> > >> How can I configure IDLE to open the Python 3.2.2 version?
> > >
> > > Try typing 'idle3' instead of 'idle'.
> > Iidle3 from the terminal does not work. I get an error "IDLE can't import
> > Tkinter. Your Python may not be configured for Tk."   Same error if I
> just
> > type idle.
> > I can launch Python3 from the terminal.
> > I can launch IDLE 2.7.1 from the GUI. I am new to Linux and am a bit lost
> > trying to troubleshoot. It seems like an install problem or a
> configuration
> > problem but I can't figure it out.
> > I have Python/IDLE3 working on Mac and Windows but I need it on Linux for
> a
> > class project.
>
> Sorry, I don't have an Ubuntu system at hand to test with and I'm not
> sure what release you are using.  If you've installed the idle-python3.2
> package, presumably all the dependencies should have been installed.  It
> also looks like Ubuntu installs the idle script as
> /usr/bin/idle-python3.2.  Try that.  You might want to ask on an Ubuntu
> forum.
>

In my Ubuntu installation (version 10.10 a.k.a. Maverick) I only see Python
3.1 in Aptitude, not 3.2. Did you install manually from source? If so then
that means you needs to install dependencies manually, and you probably
haven't installed Tkinter or Tcl/Tk (used by Tkinter) in a way that your
installation of Python 3.2 can recognize.

Do you really need Python 3.2? You can install version 3.1 of Python using
Aptitude (manually with the command line or using Synaptic), and you should
get a working version of IDLE with Python 3.1.

If you really need Python 3.2, on its download page[1] there is a link to a
page regarding Tkinter[2] which should contain the required information on
which version of Tcl/Tk you need to install, and perhaps how.

Please tell us how this worked out for future reference!
- Tal Einat

[1] http://python.org/download/releases/3.2.2/
[2] http://python.org/download/mac/tcltk
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/idle-dev/attachments/20111017/47470a14/attachment.html>


More information about the IDLE-dev mailing list