[Image-SIG] Re: pil error

Ziying Sherwin sherwin@nlm.nih.gov
Tue, 15 Jan 2002 14:16:54 -0500 (EST)

Thanks for the help. Here is the result:

1. We re-installed zlib, but got the same error message while trying to
compile pil dynamic library.

2. Then we remove zlib from Setup.in, we again got the loooong error
messages except it does not complain about zlib any more. It complains
about symbols in libimaging/libImaging.a are "relocations remain against
allocatable but non-writable sections"

Any ideas?

Ziying Sherwin

On Tue, 15 Jan 2002, Calvin wrote:

> install libz or remove it from the config file or fix it's path.
> this should be mentioned in the README.
> -calvin
Original message:

>From sherwin@hume.nlm.nih.gov Tue Jan 15 11:27:22 2002
Date: Tue, 15 Jan 2002 11:27:06 -0500 (EST)
From: Ziying Sherwin <sherwin@hume.nlm.nih.gov>
To: image-sig@python.org
Subject: Error building PIL 1.1.2 dynamic library on Solaris 2.8 with gcc

We tried to build Python Imaging Library(PIL 1.1.2) with Python 2.1.1 and gcc 
3.0 on our Solaris 2.8 machine. Everything went on smoothly until when we tried to build dynamic library at the top level directory. We got the following 
error messages:

gcc -shared  ./_imaging.o ./decode.o ./encode.o ./map.o ./display.o ./outline.o
./path.o  libImaging/libImaging.a -L/depot/lib -ljpeg -L/depot/lib -lz  -o ./_imaging.so
Text relocation remains                         referenced
    against symbol                  offset      in file
<unknown>                           0x14c       libImaging/libImaging.a(Unpack.o)
<unknown>                           0x150       libImaging/libImaging.a(Unpack.o)
<unknown>                           0x154       libImaging/libImaging.a(Unpack.o)
<unknown>                           0x158       libImaging/libImaging.a(Unpack.o)
<unknown>                           0x15c       libImaging/libImaging.a(Unpack.o)
<unknown>                           0x160       libImaging/libImaging.a(Unpack.o)
<unknown>                           0x4b4       /depot/lib/libz.a(inflate.o)
<unknown>                           0x4b8       /depot/lib/libz.a(inflate.o)
<unknown>                           0x4bc       /depot/lib/libz.a(inflate.o)
<unknown>                           0x4c0       /depot/lib/libz.a(inflate.o)
<unknown>                           0x4c4       /depot/lib/libz.a(inflate.o)
ImagingTransformAffine              0x3c38      libImaging/libImaging.a(Geometry.o)
ImagingTransformAffine              0x3d68      libImaging/libImaging.a(Geometry.o)
ImagingCopy                         0x64        libImaging/libImaging.a(Bands.o)ImagingCopy                         0xdc        libImaging/libImaging.a(Blend.o)[...]
.rem                                0x44        libImaging/libImaging.a(Offset.o)
.rem                                0x64        libImaging/libImaging.a(Offset.o)
.rem                                0xc0        libImaging/libImaging.a(Offset.o)
memset                              0x1948      libImaging/libImaging.a(Draw.o)
memset                              0x1b28      libImaging/libImaging.a(Draw.o)
memset                              0x2080      libImaging/libImaging.a(Draw.o)
<unknown>                           0x638       /depot/lib/libz.a(inffast.o)
<unknown>                           0x63c       /depot/lib/libz.a(inffast.o)
<unknown>                           0x8a0       /depot/lib/libz.a(inffast.o)
<unknown>                           0x8a4       /depot/lib/libz.a(inffast.o)
ld: fatal: relocations remain against allocatable but non-writable sections
collect2: ld returned 1 exit status
*** Error code 1
make: Fatal error: Command failed for target `_imaging.so'

The error messages ran several pages and we have no idea about what is going on.
The version of the packages that we use is jpeg 6b and zlib 1.1.3.
Does anyone have similiar experience and have solutions?

Thanks in advance.
Ziying Sherwin

P.S. I am not on the mailing list, please send your response to: