[Image-SIG] Re: python version compatibility

Fredrik Lundh fredrik at pythonware.com
Fri Nov 5 13:19:19 CET 2004

Tristan Hill wrote:

> From the readme with 1.1.5b1 the library is stated to run under python
> 1.5.2.  Does this mean that any contributed code is required to be
> compatible with python 1.5.2 (i.e use no python2 features)?  I'm
> needing to make changes to the sane module if that is of any relevance.

the core library (PIL itself) is tested and verified under 1.5.2, and all contributions
to the core must be compatible with 1.5.2 (this may change when we get to 1.2.X,
but probably not before that -- I still maintain 1.5.2-based systems)

the contributed Sane library is provided "as is" (that is, as provided by the
current maintainer).  if you need 1.5.2 support and are willing to fix this, I'm
happy to include your patches (but please coordinate with the current maintainer
first; see Sane/README for contact info).

(and yes, I'll fix PIL's own README to make this a bit clearer)

regards /F 

More information about the Image-SIG mailing list