[Image-SIG] jpeg decoder with PIL 1.1.5

luby liao lubyliao at gmail.com
Thu Dec 29 04:54:42 CET 2005

I  run into the same problem as Mathieu when trying to install PIL on a Celeron
D 64 machine.  I noticed that there were two set of libjpeg.so.62.0.0 in
the  libjpeg rpm:


They have different byte counts:

[liao at fc42541 halloween]$ ls -l /usr/lib64/libjpeg.so.62.0.0
-rwxr-xr-x  1 root root 141544 Mar  2  2005 /usr/lib64/libjpeg.so.62.0.0
-rwxr-xr-x  1 root root 124696 Mar  2  2005 /usr/lib/libjpeg.so.62.0.0

I suspected that the build process used the wrong file from
so I removed it.   This solved my problem.  I hope this is helpful for some
people with similar problem.

cheers, Luby Liao

Hi there,
I am trying to install PIL 1.1.5 with jpeg decoder.
I installed from RPM and also from sources the libjpeg-6b into
I change the ROOT_JPEG in setup.py to point to that location.
When I install PIL 1.1.5, I get a message that the JPEG support is OK.
But when I test it, I get a message of decoder error. Someone could help
me? I tried by myself in python and received the same IOError message.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.python.org/pipermail/image-sig/attachments/20051229/f64d3922/attachment-0001.htm 

More information about the Image-SIG mailing list