[Image-SIG] Crash during make step of installing image library. HELP!!

Wes Fraser wesley.fraser at nrc.ca
Fri Jan 14 20:56:13 CET 2005

I am having some issues installing PIL with jpeg support onto my 
machine. I am running mac os x 10.3 with python 2.3. I have the factory 
install of python and have tried it with custom installs of 2.3.4 with 
no success.

  I have installed libjpeg from source and have tried it with the fink 
install and have not been able to make either work.

  IFollowing the instructions on


  and after installing libjpeg with fink

  In Imaging-1.1.3/libImaging do a

  $LDFLAGS="-L/sw/lib"; CPPFLAGS="-l/sw/lib";  ./configure

  then do a

  $ make

  at this point I get the warning:

  ranlib: file: libImaging.a(Dib.o) has no symbols

  The web page says to ignore this and continue.

  So I then do

  cd ..

  python setup.py build

  and it crashes with the following error:

  Tk/tkImaging.c:198: warning: passing arg 3 of `Tcl_CreateCommand' from 
incompatible pointer type

  gcc -Wl,-F. -bundle -framework Python 
build/temp.darwin-7.7.0-Power_Macintosh-2.3/Tk/tkImaging.o -LlibImaging 
-lImaging -o build/lib.darwin-7.7.0-Power_Macintosh-2.3/_imagingtk.so

  ld: Undefined symbols:






  error: command 'gcc' failed with exit status 1

  Can you guys help me out at all? I have no idea why this went wrong 
but it is sure driving me nutz.



More information about the Image-SIG mailing list