[Image-SIG] tricky setup for multiple pythons

David Bear David.Bear at asu.edu
Wed Aug 9 19:12:42 CEST 2006

On Tue, Aug 08, 2006 at 05:26:37PM -0700, Chris Cogdon wrote:
> On Aug 8, 2006, at 17:20, David Bear wrote:
> >I have a need to run multiple python versions. The version of python
> >that came with my distribution works for many sysadmin scripts that
> >come with that version and needs to remain in place. I also need to
> >run zope with requires a newer python version.
> >
> >I do have a PIL rpm that installed pil in the python that came with my
> >distribution. PIL found all the jpeg and png libraries it needed  for
> >that version so I am confident that everything PIL wants is installed
> >in  my system.
> >
> >so I built python  with prefix=/work/webenv
> >
> >now, when I build PIL I used that particular version of python and
> >invoke it as
> >
> >/work/webenv/bin/python setup.py build_ext
> >
> >the PIL setup cannot find libjpeg..
> >
> >so I modified setup.py and hardwire the directories
> >
> >JPEG_ROOT = "/usr/lib64"
> >ZLIB_ROOT = "/usr/lib64"
> >
> >Still, setup.py cannot find jpeg libraries..
> >
> >I'm really lost on what setup.py is really looking for, and how to
> >make sure it finds it.
> >
> >Again, I do have PIL installed and working for the version of python
> >that was packaged with my distribution. But I need a different version
> >of python to run zope. Any pointers would be appreciated.
> Setup needs the include files, not the libraries. Make sure you have 
> the '-devel' versions of the packages for the libraries installed.

thanks. I assumed the rpm for PIL would have looked for devel packages
-- but it looks like it was all precompiled.

David Bear
phone: 	602-496-0424
fax: 	602-496-0955
College of Public Programs/ASU
University Center Rm 622
411 N Central
Phoenix, AZ 85007-0685
 "Beware the IP portfolio, everyone will be suspect of trespassing"

More information about the Image-SIG mailing list