[Image-SIG] Unable to get PIL to load jpeg images - Success

peter.mosley at dsl.pipex.com peter.mosley at dsl.pipex.com
Wed Feb 8 22:42:31 CET 2006

Success!  Though not without some drama along the way

I deleted the _imaging*.so files and reinstalled PIL - no change.  So I next
backed up and removed the entire PIL directory and reinstalled - still no
change.  Then I thought that maybe the files are created first in the setup
directory and copied across.  So I deleted all the setup files and reinstalled
from the original tarball.

This time it looked like disaster - Python didn't even get as far as Imaging,
but fell over somewhere in Tkinter with a message about Tclerror(?).  I went
back to the install and ran the setup test which seemed to complete ok - I think
it said 55 tests passed.  I reran my jpg test script, and this time it worked!

I can't recall the exact Tcl error message, and it's scrolled off screen by now,
so I just hope that it doesn't recur.  It looks as if everything is working.

Thanks for all the guidance.


More information about the Image-SIG mailing list