[Image-SIG] PIL-1.1.5 jpeg decoder

Scott Nelson scott_nelson86 at hotmail.com
Thu Jun 22 19:55:32 CEST 2006

I'm installing Imaging-1.1.5 on rhel 4.3.   selftest.py fails bcs "decoder 
jpeg not available". I have tried going through the steps on Fredrik Lundh's 
zone.effbot.org page for "decoder jpeg not available" at 
http://effbot.org/zone/pil-decoder-jpeg-not-available.htm.  The first step 
is to run ./configure in the libImaging directory. I don't have a configure 
script in there. Am I missing something?

I have Imaging-1.1.5 running on a CentOS-4.3 box. There is no configure in 
libImaging/ there either.

I tried changing setup.py to point to the libjpeg directory but it still 
doesn't find the decoder.

What can I try?     python -vv -c "import _imaging" gives the following:
# trying /zope/python/lib/python2.3/site-packages/_imagingmodule.so^M
# trying /zope/python/lib/python2.3/site-packages/_imaging.py^M
# trying /zope/python/lib/python2.3/site-packages/_imaging.pyc^M
Traceback (most recent call last):^M
  File "<string>", line 1, in ?^M
ImportError: No module named _imaging^M
# clear __builtin__._^M
# clear sys.path^M


More information about the Image-SIG mailing list