[Image-SIG] libjpeg and pil on intel mac os x

Josh Stephenson josh at clearwired.com
Tue May 30 19:05:53 CEST 2006

I'm running an intel mac 10.4 with python 2.4.2 and trying to install
pil 1.1.5.  I have already configured jpeg-6b.  Here's how I configured
./configure --enabled-shared --includedir=/usr/local/include

It installed with no errors.

I modified the setup.py file inside the Imaging-1.1.5 directory to point
to these directories.  When I run python setup.py build_ext -i it says:
JPEG support ok

but then I run 'python selftest.py' and I get:

Failure in example: _info(Image.open("Images/lena.jpg"))
from line #24 of selftest.testimage
Exception raised:
Traceback (most recent call last):
  File "./doctest.py", line 499, in _run_examples_inner
    exec compile(source, "<string>", "single") in globs
  File "<string>", line 1, in ?
  File "./selftest.py", line 21, in _info
  File "PIL/ImageFile.py", line 180, in load
    d = Image._getdecoder(self.mode, d, a, self.decoderconfig)
  File "PIL/Image.py", line 328, in _getdecoder
    raise IOError("decoder %s not available" % decoder_name)
IOError: decoder jpeg not available
1 items had failures:
   1 of  55 in selftest.testimage
***Test Failed*** 1 failures.
*** 1 tests of 55 failed.

It isn't finding the jpeg decoder when I know it's there.  Any help
would be awesome!

More information about the Image-SIG mailing list