[Image-SIG] Problem with jpeg decoder and PIL

Jack Wu wulabs at gmail.com
Fri Sep 22 03:12:20 CEST 2006


I'm specifically having problems with the JPEG support on OSX 10.3 PPC.
I got Fink to install jpeglib

I ran PIL's setup.py with the automatic paths i.e. '*ROOT = None'
(should automatically use
'/sw' due to fink)

running install
running build
running build_py
running build_ext
version       1.1.5
platform      darwin 2.4.1 (#2, Mar 31 2005, 00:05:10)
              [GCC 3.3 20030304 (Apple Computer, Inc. build 1666)]
*** TKINTER support not available
--- JPEG support ok
--- ZLIB (PNG/ZIP) support ok
*** FREETYPE2 support not available
To add a missing option, make sure you have the required
library, and set the corresponding ROOT variable in the
setup.py script.

To check the build, run the selftest.py script.
running build_scripts
running install_lib
running install_scripts
changing mode of
/Library/Frameworks/Python.framework/Versions/2.4/bin/pilconvert.py to
changing mode of
/Library/Frameworks/Python.framework/Versions/2.4/bin/pildriver.py to
changing mode of
/Library/Frameworks/Python.framework/Versions/2.4/bin/pilfile.py to 755
changing mode of
/Library/Frameworks/Python.framework/Versions/2.4/bin/pilfont.py to 755
changing mode of
/Library/Frameworks/Python.framework/Versions/2.4/bin/pilprint.py to

Ok, but then i ran the self test and apparenlty doesn't work:
python selftest.py
Failure in example: _info(Image.open("Images/lena.jpg"))
from line #24 of selftest.testimage
Exception raised:
Traceback (most recent call last):
  File "./doctest.py", line 499, in _run_examples_inner
    exec compile(source, "<string>", "single") in globs
  File "<string>", line 1, in ?
  File "./selftest.py", line 21, in _info
  File "PIL/ImageFile.py", line 180, in load
    d = Image._getdecoder(self.mode, d, a, self.decoderconfig)
  File "PIL/Image.py", line 328, in _getdecoder
    raise IOError("decoder %s not available" % decoder_name)
IOError: decoder jpeg not available
1 items had failures:
   1 of  55 in selftest.testimage
***Test Failed*** 1 failures.
*** 1 tests of 55 failed.

I also tried building the jpegLib (successfull) and adding that path
('/usr/local/lib') to the JPEGROOT = "" line in the setup.py, and
resetup PIL.  This has same results as above.

More information about the Image-SIG mailing list