[Image-SIG] Need help installing PIL 1.1.5 on OSX (LONG)

Jack Wu wulabs at gmail.com
Fri Sep 22 20:56:31 CEST 2006

Wow Bob,

Good suggestion.  The application I'm using is Engal on Turbogears, a
prototype photosharing web app.   The JPEG photos now load correctly.

The Gif images do not, and I get a "IOError: cannot write mode P as
JPEG", but I will leave that to another thread after I do some

So I guess I will remove all other PIL / LIBJPEG sources, install
files, etc....and just rely on the package that seems to work.

Thanks for the help guys!  I appreciate it!


On 9/22/06, Bob Ippolito <bob at redivi.com> wrote:
> On 9/22/06, Jack Wu <wulabs at gmail.com> wrote:
> > Hi Bob,
> >
> > I used this package:
> > PIL-1.1.5-py2.4-macosx10.4.zip
> >
> > It was an OSX GUI installer, which completed successfully.
> >
> > "This leads me to believe that you're not loading the installed PIL
> > when running this selftest.py. The PIL on that page definitely works
> > fine, and it's got nothing to do with 10.3.9. You should try actually
> > using it."
> > -Ok, I installed it already....hence my previous email where I stated
> > that the _imaging.so package in my main Python directory changed sizes
> > to 931KB.
> > Are you suggesting I run self-test.py from inside the
> > "PIL-1.1.5-py2.4-macosx10.4.zip" package?  What directory would that
> > be in, as all I see is a single package file, and it doesn't give any
> > documentation as to where it installed PIL?
> It installs it to the site-packages directory. It actually will tell
> you exactly where it's going to put stuff if you click "customize" and
> read the descriptions for the component packages.
> There isn't a selftest installed. What I suggested was trying to
> actually use it. My guess is that something in your PIL source
> directory is getting imported instead of the installed verison, so the
> selftest there fails.
> If it still doesn't work, then install the legacy package, which was
> built and tested with the exact platform/python combination you're
> using.
> > "-rw--w----   1 bob  admin  1770444 Apr 19 09:23"
> > What file is this?  Is my _imaging.so supposed to be 1770KB?
> Yes. Perhaps the installer in Mac OS X 10.3 does arch stripping though.
> -bob

Jack Wu

More information about the Image-SIG mailing list