[Image-SIG] Plone - The _imaging C module is not installed (Solaris 9)

Engelkins, Patric P patric.engelkins at verizonbusiness.com
Mon Apr 9 17:40:18 CEST 2007

Hello all,


I've been working on this one issue for about two weeks and I'm at my
wits end. :-(


I'm trying to get the user picture upload feature of Plone/Preferences
to work but I keep

getting the error:


The _imaging C module is not installed


Now I've had the help of a programmer and a Solaris admin and we've
Google and tried 

several things but none have worked. Yes, I have successfully installed
PIL-1.1.5 and 1.1.6 as

the Plone install from source explains. And how the PIL README states.




There is not much information on guides out there specifically targeting
the Solaris environment so this

has definitely been a trial and error. I've gotten everything but this
_imaging C module thing working as it

should be.


Here is my current environment and error details:


SUN E4000 - SunOS  5.9 Generic_118558-24 sun4u sparc


I have installed all the dependencies as suggested for the 2.5.2 Plone
version and

Solaris 9 supporting dependencies.

















Here is all the error report that I copied and pasted:



Error Type 


Error Value 

The _imaging C module is not installed


Version Info:


Plone version: 2.5.2

Zope version: (Zope 2.9.6-final, python 2.4.3, sunos5)

Apache version:

CMF version (if known): CMF-1.6.2

Browser(s) and version(s): Mozilla/5.0 (Windows; U; Windows NT 5.1;
en-US; rv: Gecko/20070309 Firefox/

Operating system: sunos5

Python version: 2.4.3 (#1, Jul 31 2006, 06:30:48) 

[GCC 3.3.2]

Debug mode: No


Installed Products:


Marshall 0.6.6-final  

MimetypesRegistry 1.4.1-final installed 

OFSP OFSP-1-0-0  

PageTemplates PageTemplates-1-4-0  

PasswordResetTool 0.4.2 installed 

PlacelessTranslationService 1.3.4  

PloneErrorReporting 1.0 installed 

PloneLanguageTool 1.5  

PlonePAS 2.2 installed 

PloneTestCase 0.9.0  

PloneTranslations 2.6.1  

PluggableAuthService PluggableAuthService-1.4.1  


PluginRegistry 1.1.1  

PortalTransforms 1.5.0-final installed 

PyboomSkin 1.2 installed 

PythonScripts PythonScripts-2-0-0  

ResourceRegistries 1.3.4 installed 

SecureMailHost 1.0.4  


SiteAccess SiteAccess-2-0-0  


StandardCacheManagers StandardCacheManagers-1-1-0  

TAKAKoboltTheme 1.0.1  




ZCatalog ZCatalog-2-2-0  



ZReST 1.1  


ZWiki ZWiki-0-58-0  

ZopeTutorial Zope Tutorial 1.2  

kupu kupu 1.3.9 installed 

statusmessages 2.0.1  

validation 1.5.0-final  




Traceback (innermost last):

  Module ZPublisher.Publish, line 115, in publish

  Module ZPublisher.mapply, line 88, in mapply

  Module ZPublisher.Publish, line 41, in call_object

  Module Products.CMFFormController.FSControllerPageTemplate, line 90,
in __call__

  Module Products.CMFFormController.BaseControllerPageTemplate, line 28,
in _call

  Module Products.CMFFormController.ControllerBase, line 232, in getNext

   - __traceback_info__: ['id = personalize_form', 'status = success',
'button=Save', 'errors={}', 'context=<PloneSite at nemesys>',
'kwargs={}', 'next_action=None', '']

  Module Products.CMFFormController.Actions.TraverseTo, line 38, in

  Module ZPublisher.mapply, line 88, in mapply

  Module ZPublisher.Publish, line 41, in call_object

  Module Products.CMFFormController.FSControllerPythonScript, line 104,
in __call__

  Module Products.CMFFormController.Script, line 145, in __call__

  Module Products.CMFCore.FSPythonScript, line 108, in __call__

  Module Shared.DC.Scripts.Bindings, line 311, in __call__

  Module Shared.DC.Scripts.Bindings, line 348, in _bindAndExec

  Module Products.CMFCore.FSPythonScript, line 164, in _exec

  Module None, line 31, in personalize

   - <FSControllerPythonScript at /nemesys/personalize>

   - Line 31

  Module Products.PlonePAS.tools.membership, line 445, in

  Module Products.CMFPlone.MembershipTool, line 181, in

  Module Products.CMFPlone.utils, line 754, in scale_image

  Module PIL.Image, line 1372, in save

  Module PIL.ImageFile, line 155, in load

  Module PIL.ImageFile, line 223, in load_prepare

  Module PIL.Image, line 36, in __getattr__

ImportError: The _imaging C module is not installed



Yet when installing the PIL product it installs without error?!


Other details:


I've created a zadmin user with a zope group


The whole site is in its own directory:



zadmin at u2:> ls

total 18

drwxr-xr-x   9 zadmin   zope         512 Apr  3 11:07 Zope-2.9.6-final/

drwxr-xr-x   2 zadmin   zope        1024 Apr  3 11:38 bin/

drwxr-xr-x   2 zadmin   zope         512 Apr  3 11:36 doc/

drwxr-xr-x  10 zadmin   zope         512 Apr  3 14:08 instance1/

drwxr-xr-x   3 zadmin   zope         512 Apr  3 11:34 lib/

drwxr-xr-x  10 zadmin   zope         512 Apr  3 11:36 skel/

drwxr-xr-x   5 zadmin   zope        1024 Apr  3 15:14 source/


I've been consistent with using python2.4 when running any python


I direct zope build to use python 2.4 as well.


I've updated the the zadmin $PATH  (via .profile permanently)

zadmin at u2:> echo $PATH






zadmin at u2:> echo $LD_LIBRARY_PATH



Debug Information

*	Zope version: (Zope 2.9.6-final, python 2.4.3, sunos5) 
*	Python version: 2.4.3 (#1, Jul 31 2006, 06:30:48) [GCC 3.3.2] 
*	System Platform: sunos5 
*	SOFTWARE_HOME: /u01/app/zope/lib/python 
*	INSTANCE_HOME: /u01/app/zope/instance1 
*	CLIENT_HOME: /u01/app/zope/instance1/var 
*	Process ID: 18363 (4) 
*	Running for: 22 min 5 sec 
*	sys.path: 


Please, if you need any other information let me know. This is the last
issue and then the site is

100% functional and I can start configuring it to be our new team


Thank you,



-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.python.org/pipermail/image-sig/attachments/20070409/428c0f9e/attachment.htm 

More information about the Image-SIG mailing list