[Image-SIG] problems with selftest on OS X intel XServe

cristopher pierson ewing cewing at u.washington.edu
Fri Feb 23 00:13:00 CET 2007

Hi all,

I'm trying to build PIL to include it in python for support of a 
zope/plone installation.  All my tests so far have been on a dev machine 
with the pre-built binaries, which include PIL.  Now I'm working on my 
server, a new Intel XServe box running OS X 10.4.8.

I'm working with a compiled installation of Python 2.4.4, built earlier 
today from source.

$ python2.4 setup.py build_ext -i
works just fine, I get all the expected output, including the information 
that support for my required features is okay:

version       1.1.6
platform      darwin 2.4.4 (#1, Feb 22 2007, 10:42:01)
               [GCC 4.0.1 (Apple Computer, Inc. build 5367)]
--- TKINTER support ok
--- JPEG support ok
--- ZLIB (PNG/ZIP) support ok
--- FREETYPE2 support ok

Great!  So I run selftest.py and it fails with the following output:

Failure in example: _info(Image.open("Images/lena.jpg"))
from line #24 of selftest.testimage
Exception raised:
Traceback (most recent call last):
   File "./doctest.py", line 499, in _run_examples_inner
     exec compile(source, "<string>", "single") in globs
   File "<string>", line 1, in ?
   File "./selftest.py", line 22, in _info
   File "PIL/ImageFile.py", line 180, in load
     d = Image._getdecoder(self.mode, d, a, self.decoderconfig)
   File "PIL/Image.py", line 375, in _getdecoder
     raise IOError("decoder %s not available" % decoder_name)
IOError: decoder jpeg not available
1 items had failures:
    1 of  57 in selftest.testimage
***Test Failed*** 1 failures.
*** 1 tests of 57 failed.

Now, from that I can see that somehow the jpeg decoder is not getting 
found despite the fact that build_ext says that jpeg support is present.

I've been searching on this list over the last few hours, and found some 
posts that suggested running python -vv -c "_imaging" to verify that the 
imaging module was in the python being used, and doing so showed that it 
was not.  However, this seems to be a chicken-or-egg thing.  How can 
python have the imaging module available without me installing it?  And 
how can I install it if it fails this test?  I tried anyway to install, 
that worked fine, running `python -vv . . .` showed that it was in fact 
being imported from the expected place, but selftest fails in exactly the 
same way, every time.

Only one other thing I've noticed that might have some bearing on the 

When I first run `python2.4 setup.py build_ext -i`, there is a line at the 
very top of the output that says:

running build_ext
--- using frameworks at /System/Library/Frameworks

OS X has a standard, built-in python in the Frameworks that is version 
2.3.5.  I can't use it for zope/plone since I need 2.4, but I wonder if 
setup.py is somehow getting confused about which python to use?? 
'python2.4' in the above command is a link to the executable of my 
self-built python 2.4.4, and that's the one I want PIL to be available to.

Any help would be greatly appreciated.  Sorry if there is a solution out 
there that I've missed in my searching.  'My eyes are growing weary . . .'



Cris Ewing
CME and Telehealth Web Services
Department of Radiology Web Services
University of Washington
School of Medicine
Work Phone: (206) 685-9116
Home Phone: (206) 365-3413
E-mail: cewing at u.washington.edu

More information about the Image-SIG mailing list