[Image-SIG] Cygwin (1.5.24) PIL(1.1.6) Install Problem: tight looping

Steve Holden steve at holdenweb.com
Sat Jul 28 14:42:13 CEST 2007

Steve Holden wrote:
> Yaakov (Cygwin Ports) wrote:
>> Hash: SHA256
>> Steve Holden wrote:
>>> I have tried to install it, but each time I do I see the first compile
>>> command start to run and the process hangs. If I CTRL/C the setup.py
>>> and restart it, it begins the next compile (implying that the previous
>>> one succeeded), which again hangs. I see python.exe still running for
>>> each install run I have interrupted, which I have to kill manually.
>> Try rebaseall.
> Unfortunately I did that before I posted. Sorry, should have mentioned it.
[Note for distutils-sig readers: I am trying to track down a build issue 
with version 1.1.6 of the PIL under Cygwin - nobody else reports any 
successful or failed experiences building this package].

Here's the output from a failed setup run with a couple of debug prints 
inserted which should report how sub-process termination occurred - it 
hangs after this output.

$ python setup.py build
running build
running build_py
running build_ext
building '_imaging' extension
SPAWN: ['gcc', '-fno-strict-aliasing', '-DNDEBUG', '-g', '-O3', '-Wall', 
'-Wstrict-prototypes', '-DHAVE_LIBZ', '-IlibImaging', '-I/usr/include', 
'-I/usr/include/python2.5', '-c', 'libImaging/Chops.c', '-o', 
'build/temp.cygwin-1.5.24-i686-2.5/libImaging/Chops.o'] PATH? 1 V: 0 D:0
gcc -fno-strict-aliasing -DNDEBUG -g -O3 -Wall -Wstrict-prototypes 
IlibImaging -I/usr/include -I/usr/include/python2.5 -c 
libImaging/Chops.c -o bui
Are we done yet? Waiting on pid 3280

As a further follow up, I extracted the _spawn_all function and ran it 
under command line control.

Everything seems to work fine with other subtasks, so I am wondering 
whether this is a failure specific to gcc, which would seem kind of 
unlikely. So I ran the same compile using my test function standing 
alone, and see

sholden at bigboy ~/Imaging-1.1.6
$ python ~/Projects/Python/spawntest.py gcc -fno-strict-aliasing 
-DNDEBUG -g -O3 -Wall -Wstrict-prototypes -DHAVE_LIBZ -IlibImaging 
-I/usr/include -I/usr/include/python2.5 -c libImaging/Chops.c -o 
Are we done yet? Waiting on pid 3244
Got pid, status 3244 0

So it appears unlikely to be gcc-specific, leaving me wondering what 
exactly is the difference between the build environment and my tests.

Steve Holden        +1 571 484 6266   +1 800 494 3119
Holden Web LLC/Ltd           http://www.holdenweb.com
Skype: holdenweb      http://del.icio.us/steve.holden
--------------- Asciimercial ------------------
Get on the web: Blog, lens and tag the Internet
Many services currently offer free registration
----------- Thank You for Reading -------------

More information about the Image-SIG mailing list