[Image-SIG] PIL DPI trouble

Luca De Santis lucadex at gmail.com
Mon Sep 17 09:36:16 CEST 2007

That's exactly the same problem I incurred into.
I tried PIL  version 1.1.6 on a Mac OS X 10.4 and on an old Linux box
and can't get the DPI attribute for JPEG and PNG files that I've
created with Photoshop.

I tested that both on Python 2.5 and Python 2.1.3 with the same result.

I tried also to update libjpeg on Linux but nothing changes.

Any help on that is greatly appreciated.


On 9/14/07, Gary Bloom <bloominator at hotmail.com> wrote:
> I notice that the PIL has trouble playing with the DPI of other programs and
> image standards: when I create a file with Paint Shop Pro or Photoshop, the
> PIL routines can't properly recognize the DPI.  And when I create an image
> file (via the save method) of PIL, setting the DPI, those same two programs
> can't read the DPI as set by them.  Is there a workaround for this?
> Other than this one issue, I have found the PIL to be a BLAST!  :)
> Thanks!
> Gary Bloom

Luca De Santis
Pisa, Italy

More information about the Image-SIG mailing list