[Image-SIG] Help: Converting PIL to Tkinter image objects crashes python

Fredrik Lundh fredrik at pythonware.com
Fri Jul 10 00:44:25 CEST 2009

On Thu, Jul 9, 2009 at 11:50 PM, Tom Baldwin<tbaldwin at uoregon.edu> wrote:

> A python-help volunteer suggested downgrading my Tcl/Tk installation from
> 8.5 to 8.4, which seems a little weird, since 8.5 has been stable since
> December 2007.

1.1.6 was released in december 2006, and core Python didn't switch to
8.5 until release 2.6 in late 2008 (iirc).

> (Also, downgrading things using Macports is so complicated
> that I haven't succeeding in doing it yet.) He directed me to this list for
> more knowledgeable help.
> Can anyone with PIL familiarity tell me what might be causing this error? Or
> say if there is any reason to believe that Tcl 8.4 might be more compatible?

Instead of downgrading the Tcl/Tk install, you could try updating to
the 1.1.7 trunk version of Tk/tkImaging.c module, available from:


There's been a couple of tweaks related to 8.4/8.5 compatibility; not
sure if they affect your specific case, but since you're building from
source, it shouldn't be that hard for you test this.


More information about the Image-SIG mailing list