[Image-SIG] weird windows 7 error with ImageFont

Laura & Edward Cannon cannon.el at gmail.com
Wed May 5 17:00:59 CEST 2010

running the selftest.py I find the following output:

Python modules loaded from C:\Python26\lib\site-packages\PIL
Binary modules loaded from C:\Python26\lib\site-packages\PIL
--- PIL CORE support ok
--- TKINTER support ok
--- JPEG support ok
--- ZLIB (PNG/ZIP) support ok
*** FREETYPE2 support not installed
--- LITTLECMS support ok
Running selftest:
--- 57 tests passed.

I tried installing freetype2 from the GnuWin people
(http://gnuwin32.sourceforge.net/packages/freetype.htm) but that
didn't seem to help, even with a reinstall of PIL. Do I need to try to
recompile PIL or do something else? sxstrace output doesn't seem
helpful to me either, unfortunately most of my C experience is on
other OS's, but I'm willing to play around.

On Wed, May 5, 2010 at 6:57 AM, Fran Boon <francisboon at googlemail.com> wrote:
> On 5 May 2010 04:48, Fredrik Lundh <fredrik at pythonware.com> wrote:
>> What binaries are we talking about?  I'm pretty sure the effbot.org
>> binaries have _imagingft in them, at least:
> The file is there, but won't import on my Windows 7 64-bit Python-2.6 machine.
> The Application log shows a Side-by-Side error:
> http://blogs.msdn.com/junfeng/archive/2006/04/14/576314.aspx
> sxstrace output can be provided, but it doesn't seem helpful to me...
> Downgrading to 1.1.6 worked for me.
> Best Wishes,
> Fran.

More information about the Image-SIG mailing list