[Image-SIG] [Pythonmac-SIG] PIL binaries -- please test

Matthias Baas matthias.baas at gmail.com
Wed May 26 00:30:20 CEST 2010

aditya bhargava wrote:
> How do you determine which version of Python to build for? I'm on 10.4
> and I've got two versions of Python – python2.3 in /usr/bin/python and
> python2.5 in /opt/local/bin/python. python2.5 is my default (i.e. the
> one that shows when I run 'which python'), but the package installer
> doesn't seem to recognize it. It gives me an error saying "You cannot
> install PIL 1.1.7 on this volume. PIL requires System Python 2.5 to
> install".

Apparently, you got your Python 2.5 from MacPorts (as it's in
/opt/local). As far as I know, such installers as provided by
Christopher only work with the Python version you can download on
python.org (or the system Python probably) whereas if you want extension
modules for your MacPorts Python you also have to use MacPorts to
install them.


- Matthias -

More information about the Image-SIG mailing list