[Image-SIG] IOError "decoder jpeg not available" on Win7 (2nd try)

David lists at theflorys.org
Mon Sep 27 03:38:35 CEST 2010

On 9/24/2010 2:00 PM, Edward Cannon wrote:
> the only things I can think of is writing a script that opens a jpeg and
> trying that or maybe trying 1.1.6 instead of 1.1.7. I personally don't
> use the pilconvert script, that might be the problem
> On 9/24/2010 7:44 AM, David wrote:
>> On 9/8/2010 6:04 PM, Edward Cannon wrote:
>>> That seems weird. I have win7 and python 2.6 and do not have any
>>> problems. Maybe a clean install will help.
>>> Edward Cannon
>>> Unicorn School
>>> On Sep 8, 2010, at 1:08 PM, David <lists at theflorys.org> wrote:
>>>> I sent this to the list a week ago with no result. 2nd try.
>>>> I am running Python 2.6 on a new Win7 machine. I have installed PIL
>>>> from the PIL-1.1.7.win32-py2.6.exe binary. I am trying to resize a
>>>> jpg. I get the IOError message "decoder jpeg not available" when I
>>>> call the save() method:
>>>> im = Image.open(infile)
>>>> im = im.resize(newsize,Image.ANTIALIAS)
>>>> im.save(outfile, "JPEG", quality=90)
>>>> I have scanned a year of back messages on this list without seeing any
>>>> relevant advice. I have used PIL with the same code on other Win32
>>>> machines without problems. Since it is a prebuild binary, the jpeg
>>>> decoder should be present.
>>>> Help or advice would be appreciated.
>>>> David Flory
>>>> _______________________________________________
>>>> Image-SIG maillist - Image-SIG at python.org
>>>> http://mail.python.org/mailman/listinfo/image-sig
>> I just did a clean install of PIL 1.1.7 from the Win32 binary. I still
>> get an error message when I run pyconvert. Here is my command:
>> C:\Users\David\Pictures\test>pilconvert test.jpg test.png
>> cannot convert image (<type 'exceptions.IOError'>:decoder jpeg not
>> available)
>> What file contains the "decoder jpeg" and how might I find it?
>> David

I solved the problem on my third "re-install PIL"  The problem was that 
on Win7 the installation puts a copy in my


directory BUT (the kicker) I had a second installation in my


that also had to be deleted before doing the reinstall.  The second one 
may come from PyPM.  I am not sure but deleting it solved the problem.

Thanks to all for the suggestions.


More information about the Image-SIG mailing list