[Image-SIG] Installing PIL

Brenden Brown brenden.brown at gmail.com
Wed Nov 16 03:12:19 CET 2011

Hi all,

I'm trying to install PIL, and get an error "Python version 2.7 required,
which was not found in the registry".  What registry values do I need?

I'm running Windows 7 SP1

1) Install Python 2.7 from http://www.python.org/download/releases/2.7.2/,
Windows x86 MSI Installer (2.7.2) with the following information in the

Author: Secret Labs AB (PythonWare)
Author_email: info at pythonware.com
Description: Python Imaging Library
Name: PIL
Url: http://www.pythonware.com/products/pil
Version: 1.1.7

2) Run PIL executable from http://effbot.org/downloads/#imaging or
http://www.pythonware.com/products/pil/, the 2.7 version

I've verified the registry information contains what is added in the script
at http://effbot.org/zone/python-register.htm:
In HKLM\Software\Python\PythonCore\2.7 there is InstallPath="C:\Python27"
and PythonPath="C:\Python27\Lib;C:\Python27\DLLs;C:\Python27\Lib\lib-tk"

I've verified that Python 2.7 is installed to those locations.

I've been learning Python starting last week, and this is the first time
I've tried to install a module. I would appreciate any help in
troubleshooting this error.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/image-sig/attachments/20111115/9fb60c32/attachment-0001.html>

More information about the Image-SIG mailing list