[IPython-dev] wxIPython 0.6 (Multithreaded and current bug list flushed)

Prabhu Ramachandran prabhu at aero.iitb.ac.in
Wed Dec 12 06:47:40 EST 2007

Laurent Dufrechou wrote:
> If any linux guy could test it, (mine is currently dead :() and report any
> bugs.
> I'm concerned about locale support. Currently it works well in French...

This looks very cool and I'd love to be able to use this in various 
other tools.

I am running into some problems.  I'm using Ubuntu gutsy with 
wx.__version__ == '' and the default ipython-0.8.1-1 shipped with 

When I run wxIPython.py, I run into the following.

  1. I can't see what I type, altho you have the FG set to WHITE it 
renders it black.  So unless I change the BG (in ipython_view.py) to 
something else that is light I can't see the cursor or any test I type.

  2. Regardless of 1 if I do type anything I get the following

In [1]: print "hello"
<type 'exceptions.TypeError'>             Traceback (most recent call last)

/var/lib/python-support/python2.5/IPython/iplib.py in raw_input(self, 
prompt, continue_prompt)
    2014         try:
-> 2015             line = 
    2016         except ValueError:
    2017             warn("\n********\nYou or a %run:ed script called 

<type 'exceptions.TypeError'>: decode() argument 1 must be string, not None
In [2]:

Sorry I can't debug anymore, I just thought I'd give you what errors I 
was running into.


More information about the IPython-dev mailing list