[IPython-dev] starting local ipengines works great but not remote ipengines

Glen W. Mabey Glen.Mabey at swri.org
Mon Mar 12 11:44:52 EDT 2007

On Sat, Mar 10, 2007 at 01:18:52AM -0700, Fernando Perez wrote:
> On 3/9/07, Glen W. Mabey <Glen.Mabey at swri.org> wrote:
> >Hello,
> >
> >Having installed ipython1 on two different machines, I am struggling to
> >get engines on one to connect to a controller on the other.
> >
> >However, connecting to local controllers works on both machines.  One is
> >an AMD64 while the other is a P4.
> >
> >The only deviation that I have made from the build instructions is in
> >the recommendation to use Zope Interface version 3.1.0c1, which gave
> >an error when I tried to build it.  Version 3.3.0 worked with no issues.
> I'm afraid I have no clue here; but Brian knows this code much better
> than I do, and he might be able to help.
> One thing we need to do is to modify all components to use the ipython
> exception reporting system, so that we get better tracebacks than the
> primitive ones python puts out by default.  That will  help a lot in
> situations like these.
> As a long shot: do you have any firewalls between these two boxes?
> The engine is attempting a connection /into/ the controller, so if the
> host where the controller is running has a firewall, it may well be
> dropping the connection.

Nope, no firewalls.  I can even open a telnet session to the listening

> Sorry not to be of more assistance at this point...

I wonder whether this has anything to do with the state of svn for
twisted that I happened to pick up last Friday.  Could anyone [hint,
hint, Brian] tell me what svn revision number is working for them?


More information about the IPython-dev mailing list