[IPython-dev] ipython1 / python 2.3

Dan Milstein danmil at comcast.net
Mon Mar 26 12:41:15 EDT 2007

Just an FYI -- ipython1 doesn't run on python 2.3.

Should it?

I just tried to install and then run it, and ran into the following  
issues, all of which require 2.4:

  1) tests/tutils.py assumes doctest has a DocTestParser class

  2) tools/utils.py uses a generator expression on l. 55:
     return dict((k,callerNS[k]) for k in names)

  3) ipcluster imports subprocess

There may be (many) more, but those were the ones which stopped me  
from getting it working even minimally.

Also, in case it fits into this question: I'm running OS X (10.4),  
and often use the python that comes bundled with it (2.3.5).  I *do*  
have 2.4 installed, but there are some nasty bits to getting that  
working which can make some things tricky.  For (a relevant) example:  
I've so far failed to get Zope Interfaces installed under 2.4,  
because of some strange compilation issue which I haven't had time to  
debug yet.


More information about the IPython-dev mailing list