[IPython-dev] Fwd: Multi-line history problems in ipython (mac osx)

Boyd Waters bwaters at nrao.edu
Wed Jan 16 19:58:59 EST 2008

On Jan 16, 2008, at 4:37 PM, Michael VanLandingham wrote:

> So what I mean is that, in iPython, if I enter in anything that  
> spans more than one line, such as a function definition.  Say it's  
> this:
> def dog():
>    print 'bark'
> and then I want to edit that (e.g. because what I really want is for  
> dog() to print 'woof'). So I hit the up-arrow key to insert the  
> previous history entry into the current line.  But when I do the  
> terminal formatting becomes corrupted - for example, the cursor is  
> out in the middle of the row, and so on.  It makes editing almost  
> impossible.
> I think there was a better example in my original post.  It's easier  
> to show than to explain, but you'd know it if you saw it.  It  
> happens with stock Leopard & current iPython.

Oh. right.

that's a termcap issue.

comments at this blog entry

report the same problem.

I ran across another place recently where they were having that  
trouble.... hmm... I can't find it now. I'll keep looking.

Regarding <rdar://problem/5563035>, I suppose I should update that -  
I'm no longer getting duplicate completions.

I haven't tried to reproduce the ipython crasher (binding TAB key to  
unknown function causes segfault in IPython but not "stock" Python).

   - boyd

Boyd Waters

More information about the IPython-dev mailing list