[IPython-dev] Critical: For now IPython requires Python 2.5 - we need to fix this

Fernando Perez fperez.net at gmail.com
Thu Jun 12 16:46:46 EDT 2008

On Thu, Jun 12, 2008 at 1:34 PM, Robert Kern <robert.kern at gmail.com> wrote:
> Fernando Perez wrote:
>> I think we'll have to be OK with 2.4 as a dependency for versions >=
>> 0.9, but 2.5 is definitely a little harsh.  I *really* want those cool
>> context managers in there, the idea is too cool not to put it  in.
> You can define the context managers all you like as long as you don't use them
> in the library code itself. As far as I can tell, the only place you actually
> use a with statement is in the demo code at the bottom of context.py which, as
> noted in the comments, really ought to be moved into a real test suite.

Yup, correct, I forgot that the actual  managers do NOT use 'with',
they only define the special methods the with protocol uses.

We just need to move that code into the tests and make sure they get
cleanly skipped with 2.4, and we're clear.  Thanks for the reminder.

Since I'll be working on the tests, I'll take care of this.



More information about the IPython-dev mailing list