[IPython-dev] Critical: For now IPython requires Python 2.5 - we need to fix this
benjaminrk at gmail.com
Thu Jun 12 16:54:32 EDT 2008
I just did a test install in 2.4, and it works fine. It throws SyntaxErrors
during setup, but the install still completes and regular IPython works
fine. I get the SyntaxErrors again (in kernel.config) if I try to import
kernel.client, but it's certainly not a widespread problem. Only
kernel/config and kernel/contexts seem to have the issue, which should be
easy to remedy.
On Thu, Jun 12, 2008 at 1:34 PM, Robert Kern <robert.kern at gmail.com> wrote:
> Fernando Perez wrote:
> > I think we'll have to be OK with 2.4 as a dependency for versions >=
> > 0.9, but 2.5 is definitely a little harsh. I *really* want those cool
> > context managers in there, the idea is too cool not to put it in.
> You can define the context managers all you like as long as you don't use
> in the library code itself. As far as I can tell, the only place you
> use a with statement is in the demo code at the bottom of context.py which,
> noted in the comments, really ought to be moved into a real test suite.
> > But we need them to be optional. The trick is to exclude them from
> > the build process if the setup.py file is processed with python2.4,
> > since they simply won't compile at all (the with statement is a syntax
> > error).
> I have seen this give warnings, but I don't think it stops the build,
> Robert Kern
> "I have come to believe that the whole world is an enigma, a harmless
> that is made terrible by our own mad attempt to interpret it as though it
> an underlying truth."
> -- Umberto Eco
> IPython-dev mailing list
> IPython-dev at scipy.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the IPython-dev