[IPython-dev] Uniform way of integrating event loops among different IDE's

Fernando Perez fperez.net at gmail.com
Wed Aug 25 16:53:20 EDT 2010


Hi Almar,

On Wed, Aug 25, 2010 at 1:10 AM, Almar Klein <almar.klein at gmail.com> wrote:
> Hi Fernando,

> This zmq looks interesting indeed. I should take a look at it in the future.
>
> A common API, that's an interesting idea. We might even cooperate on
> creating a package specifically for this kind of inter process
> communication, that would use zmq if it can and falls back to pure Python
> otherwise.
>
> Thinking of wilder ideas, it might even be possible to share a common
> interpreter (with which I mean the code running in the second process). Such
> that only the way of controlling it is different. Whether one uses IPython
> or IEP, under the hood it's the same thing. There are of course some
> fundamental differences between IEP and IPython (for example IEP needs to be
> able to run a selection of code), but who knows?

Not wild at all, in fact all the recent work from the Google SoC
students, as well as the stuff Brian, Evan and I are currently working
on, goes precisely in that direction.  We're basically specifying an
'IPython protocol' as described here:

http://ipython.scipy.org/doc/nightly/html/development/messaging.html

That messaging spec fully defines how to interact with an ipython
kernel that has all the goodies we see today in the terminal, and any
number of frontends can talk to one.  The 'newkernel' branch in the
ipython repo has a Qt implementation of a client that uses this spec,
and it's getting to be pretty functional already.  We're doing a ton
of work on this over the next few weeks.

So yes, these ideas are definitely in line with what is being built in
ipython right now.

>> - Since this is new code, may I suggest you use PEP-8 naming
>> conventions?  While in places like code that inherits from Wx or Qt
>> one has no option but following its own naming scheme, these days most
>> python code has standardized on PEP-8 naming style (ClassNames and
>> functions_or_methods).  It would be good to see new code (especially
>> code landing for py3) arriving in a consistent style with this.
>
> You're right. I will change the names today.

Awesome, thanks.  If you want a quick reference, our coding and
documentation guides may be handy:

http://ipython.scipy.org/doc/nightly/html/development/coding_guide.html
http://ipython.scipy.org/doc/nightly/html/development/doc_guide.html

> Well, your words had a sharp edge to it, but I understood what you meant. No
> hard feelings :)

Thanks again for not reacting to the edge I added to my language when
it wasn't necessary :)

All the best,

f



More information about the IPython-dev mailing list