[IPython-dev] [IPython-User] PyZMQ 2.1.10
fperez.net at gmail.com
Thu Oct 13 21:30:38 EDT 2011
On Thu, Oct 13, 2011 at 6:05 PM, MinRK <benjaminrk at gmail.com> wrote:
> If you must use IPython 0.11 and a bdist of pyzmq, you can force pyzmq
> to install 2.1.9 with `easy_install pyzmq==2.1.9`.
Alternatively, if you know you have pyzmq 2.1.10 and don't want to
upgrade IPython at this moment, a quick and dirty fix is to manually
edit the file IPython/zmq/__init__.py, and comment out or delete these
lines towards the top:
if pyzmq_version < minimum_pyzmq_version:
raise ImportError("IPython.zmq requires pyzmq >= %s, but you have %s"%(
That should do the trick (ugly but effective).
More information about the IPython-dev