[IPython-dev] A couple of odd behaviours...

Thomas Kluyver takowl at gmail.com
Thu Nov 8 09:23:40 EST 2012

On 8 November 2012 02:42, Carl Smith <carl.input at gmail.com> wrote:

> I tried `pwd` and so on, and get the same behaviour. Everything
> printed by `!abd shell <cmd>` ends up in the terminal, not in the
> Notebook, though I still get a newline in the Notebook for each line
> that should be there.
> Any thoughts?

You don't have anything in config or startup files that could be setting
ip.system to ip.system_raw? Can you check that ip.system is
ip.system_piped, just before an offending command?

We fail to redirect C-level stdout from within the kernel process (issue
#1230), but the subprocess when you run a system command should be run in a
new pseudoterminal controlled by IPython, so I'm mystified why the output
is going to the wrong place.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/ipython-dev/attachments/20121108/61bd40a6/attachment.html>

More information about the IPython-dev mailing list