[IPython-dev] Running IPython Notebook against Python 2.7 or Python 3.3

Eric Matthes ehmatthes at gmail.com
Sat Nov 30 19:45:45 EST 2013


Hello,

I have loved working with IPython Notebook, but I've become totally
confused about how I set up my main system. I love how it is set up now; I
can start a virtualenv with ipython, that either uses python 2.7 or python
3.3. But if I try to build a similar setup on a clean install of 12.04 from
virtualbox, I can't replicate my environment.

I am not tied to using virtualenv for ipython, but I do need a reliable
setup that lets me choose to use ipython notebook with either Python 2.7 or
3.3. I've played with virtualenvs, with pip and easy_install, with symlinks
from python and python3.3 directories, with dist-packages and
site-packages, and it's left me pretty confused.

Can someone suggest a straightforward way to set up an Ubuntu 12.04 system
to use IPython Notebook, so that I can choose to have the notebook using a
Python 2.7 or Python 3.3 interpreter at different times? For context, I am
working on some tutorials that reference both 2.7 code samples and 3.3 code
samples, and I'd like to be able to run both. I have an open question on
stackoverflow about installing ipython notebook to a virtualenv, but I
don't need that particular question answered necessarily at this point if
there is a better alternative.

(so question) -
http://stackoverflow.com/questions/20290357/ipython-notebook-in-a-virtualenv-using-python-3-3

Eric Matthes
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/ipython-dev/attachments/20131130/492756e4/attachment.html>


More information about the IPython-dev mailing list