[IPython-dev] Trouble installing latest IPython 2.0 on Mac

Alessandro Gagliardi alessandro.gagliardi at glassdoor.com
Fri Feb 14 14:14:41 EST 2014

$ python setup.py symlink
$ python setup.py install


From: Alessandro <alessandro.gagliardi at glassdoor.com<mailto:alessandro.gagliardi at glassdoor.com>>
Date: Friday, February 14, 2014 at 10:22 AM
To: "ipython-dev at scipy.org<mailto:ipython-dev at scipy.org>" <ipython-dev at scipy.org<mailto:ipython-dev at scipy.org>>
Subject: Re: [IPython-dev] Trouble installing latest IPython 2.0 on Mac

In case it matters, I’m doing this in a conda environment. I’ve run conda
install pip and conda install readline (etc.) ahead of time.
I try:
$ pip install --no-deps -e "[notebook]"
and it ends with

    Installed /Users/alessandro.gagliardi/Devel/ipython
Successfully installed ipython
Cleaning up…

But when I try
$ ipython
It gives me

Traceback (most recent call last):
  File "/Users/alessandro.gagliardi/anaconda/envs/ipython2/bin/ipython",
line 5, in <module>
    from pkg_resources import load_entry_point
ages/setuptools-2.2-py2.7.egg/pkg_resources.py", line 2716, in <module>
ages/setuptools-2.2-py2.7.egg/pkg_resources.py", line 685, in require
ages/setuptools-2.2-py2.7.egg/pkg_resources.py", line 588, in resolve
pkg_resources.DistributionNotFound: readline

(FWIW, if I run strait up python and import readline, it works fine.)

Since that didn¹t work, I tried using setup.py as you recommended, but I
may have done it wrong. First:

$ python setup.py symlink
                python: 2.7.6 |Continuum Analytics, Inc.| (default, Jan 10
                        2014, 11:23:15)  [GCC 4.0.1 (Apple Inc. build
              platform: darwin

                sphinx: Not found (required for docs and nbconvert)
              pygments: Not found (required for docs and nbconvert)
                  nose: 1.3.0
               pexpect: no (will use bundled version in IPython.external)
                 pyzmq: no (required for qtconsole, notebook, and parallel
                        computing capabilities)
               tornado: no (required for notebook)
              readline: yes
                jinja2: Not found (required for notebook and nbconvert)
running symlink
running install_lib_symlink
symlinking /Users/alessandro.gagliardi/Devel/ipython/IPython ->
running install_scripts_sym
running build_scripts
. . .

$ python setup.py develop
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/ipython-dev/attachments/20140214/8bae768e/attachment.html>

More information about the IPython-dev mailing list