[IPython-dev] Possible to run Octave in IPython without %%octave ?

Matthias Bussonnier bussonniermatthias at gmail.com
Sun Oct 19 09:27:55 EDT 2014

Le 19 oct. 2014 à 13:43, Daniel Carrera <dcarrera at gmail.com> a écrit :

> Well, this is normal for the notebook,  now that the notebook support multiple kernel.
> just forget about the --kernel flag, you should get a drop down in the notebook UI to select octave kernel.
> Look in the kernel menu, or at the top right of the notebook)
> For the QT stuff can you open an issue on github  ? 
> Ok. Here it is:
> https://github.com/ipython/ipython/issues/6739

Thanks !

> I started the notebook like you said, and I can see the Octave kernel on the menu. However, it doesn't produce any output. When I type "2+2" I get nothing. Here is what I know:
> 1) With the Python kernel I do get the "Out[1]: 4". So it's not the UI per se.
> 2) Octave is running. If I try "plot( [1 2 3], [4 5 6])" I actually get a plot.
> 3) Initially the window came as a pop-up, but "%inline" fixed it. So it looks like plotting works, and the UI can actually read the plots coming out of Octave.
> 4) But I still don't get the "Out[]:" lines, even when I run "disp(3)". There are no errors on the notebook, or on the terminal. It's just silent.

There might also be an issue on octave kernel side. 
I would also open an issue on octave kernel itself, the author is probably more familiar with it than we are.

> So, I feel like everything is really close to working. I looked through the source code of the Octave kernel, but I didn't understand it enough to try anything else.

IPython 3.0 is still highly in motion, so having different things "almost" working is not too surprising. 
Though, the kernel architecture to get basic stuff working is already stable enough that not having any
output is weird. 

> As a side-note, I would like to set the figures to svg. With the old system I would write "%%octave -f svg". I cannot figure out how to do that with the new system.

This you would have to see with the octave kernel. -f svg was probably setting an option somewhere. 

Good luck ! 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/ipython-dev/attachments/20141019/5fe4a744/attachment.html>

More information about the IPython-dev mailing list