[IPython-dev] error running docker pull jupyter/demo

Robert Alexander roalexan at microsoft.com
Fri Oct 24 23:54:38 EDT 2014

I tried coming at this from a different angle, namely by download from git and bootstrapping using an "out-of-the-box" script that I found:

                sudo git clone https://github.com/jupyter/tmpnb.git
                sudo script/bootstrap

It looks like it ultimately sort of does the same thing, namely pull the jupyter/demo repository. This time around, however, it made it passed the previously failing "dependent layer"  - maybe that was a particularly large download that the network temporarily glitched on.

From: ipython-dev-bounces at scipy.org <ipython-dev-bounces at scipy.org> on behalf of Robert Alexander <roalexan at microsoft.com>
Sent: Friday, October 24, 2014 10:08 PM
To: ipython-dev at scipy.org
Subject: [IPython-dev] error running docker pull jupyter/demo

Anyone else seeing this? In setting up jupyter/tmpnb, I'm seeing:

sudo docker pull jupyter/demo
Pulling repository jupyter/demo
150a62370f1d: Pulling dependent layers
511136ea3c5a: Download complete
ebee8767795d: Download complete
113a452eaaa8: Downloading [========>                                          ] 104.1 MB/598.9 MB 3m54s
2014/10/25 01:46:13 unexpected EOF

Here's what I'm seeing if I run it again:

sudo docker pull jupyter/demo


113a452eaaa8: Error downloading dependent layers
2014/10/25 01:53:12 Could not find repository on any of the indexed registries.

This has happened to me two times in a row now on a fresh Ubuntu Server 14.04 LTS virtual machine.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/ipython-dev/attachments/20141025/acbaec39/attachment.html>

More information about the IPython-dev mailing list