[IPython-dev] Jupyter Hub Doc Issue

John Omernik john at omernik.com
Fri Feb 6 21:59:57 EST 2015

In the Jupyter Hub, there's

JupyterHub requires IPython >= 3.0 (current master) and Python >= 3.3.

You will need nodejs/npm, which you can get from your package manager:

sudo apt-get install npm nodejs-legacy

(The nodejs-legacy package installs the node executable, which is
required for npm to work on Debian/Ubuntu at this point)

Then install javascript dependencies:

However, I am running Ubuntu 12.04, and there is no nodejs-legacy.
How do I meet that requirement?


More information about the IPython-dev mailing list