[IPython-dev] entrypoints error . . . .

Kiko kikocorreoso at gmail.com
Sat Apr 23 08:38:06 EDT 2016


I've updated one extension this morning and creating the setup.py was
frustrating because of that error.

Thanks Min for the solution.

2016-04-21 15:22 GMT+02:00, giovanni <giovanni at ecfm.usac.edu.gt>:
> thank you very much for the solution, that was the problem. jupyter works
> very well.
>
> bye.
>
> On Thu, 21 Apr 2016 13:44:51 +0200, MinRK wrote
>> What is pip --version? It’s possible that you need to upgrade pip:
> sudo pip
> install --upgrade setuptools
> pip
>
>>>>
>> On Thu, Apr 21, 2016 at 7:07 AM, Brian Granger <ellisonbg at gmail.com>
>> wrote:
>>Hmmm, this is at least the second report of this we have seen. Why
>> isn't the installation just installing the entrypoints package?
>>
>> On Wed, Apr 20, 2016 at 8:48 PM, giovanni <giovanni at ecfm.usac.edu.gt>
>> wrote:
>> > When jupyter is installed the following error is generated:
>> >
>> > bilbo at ecfm:~$ sudo pip install jupyter
>> > Downloading/unpacking jupyter
>> > Downloading jupyter-1.0.0.tar.gz
>> > Running setup.py egg_info for package jupyter
>> >
>> > Downloading/unpacking notebook (from jupyter)
>> > Running setup.py egg_info for package notebook
>> >
>> > Downloading/unpacking qtconsole (from jupyter)
>> > Downloading qtconsole-4.2.1.tar.gz (408Kb): 408Kb downloaded
>> > Running setup.py egg_info for package qtconsole
>> >
>> > Downloading/unpacking jupyter-console (from jupyter)
>> > Downloading jupyter_console-4.1.1.tar.gz
>> > Running setup.py egg_info for package jupyter-console
>> >
>> > Downloading/unpacking nbconvert (from jupyter)
>> > Running setup.py egg_info for package nbconvert
>> >
>> > Requirement already satisfied (use --upgrade to upgrade): ipykernel in
>> > /usr/local/lib/python2.7/dist-packages (from jupyter)
>> > Downloading/unpacking ipywidgets (from jupyter)
>> > Running setup.py egg_info for package ipywidgets
>> >
>> > Requirement already satisfied (use --upgrade to upgrade): jinja2 in
>> > /usr/local/lib/python2.7/dist-packages (from notebook->jupyter)
>> > Requirement already satisfied (use --upgrade to upgrade): tornado>=4 in
>> > /usr/local/lib/python2.7/dist-packages (from notebook->jupyter)
>> > Requirement already satisfied (use --upgrade to upgrade):
>> > ipython_genutils
>> > in /usr/local/lib/python2.7/dist-packages (from notebook->jupyter)
>> > Requirement already satisfied (use --upgrade to upgrade): traitlets in
>> > /usr/local/lib/python2.7/dist-packages (from notebook->jupyter)
>> > Requirement already satisfied (use --upgrade to upgrade): jupyter_core
>> > in
>> > /usr/local/lib/python2.7/dist-packages (from notebook->jupyter)
>> > Requirement already satisfied (use --upgrade to upgrade):
>> > jupyter_client
>> > in /usr/local/lib/python2.7/dist-packages (from notebook->jupyter)
>> > Requirement already satisfied (use --upgrade to upgrade): nbformat in
>> > /usr/local/lib/python2.7/dist-packages (from notebook->jupyter)
>> > Requirement already satisfied (use --upgrade to upgrade): pygments in
>> > /usr/local/lib/python2.7/dist-packages (from qtconsole->jupyter)
>> > Requirement already satisfied (use --upgrade to upgrade): ipython in
>> > /usr/local/lib/python2.7/dist-packages (from jupyter-console->jupyter)
>> > Requirement already satisfied (use --upgrade to upgrade): mistune!=0.6
>> > in
>> > /usr/local/lib/python2.7/dist-packages (from nbconvert->jupyter)
>> > Downloading/unpacking entrypoints (from nbconvert->jupyter)
>> > Could not find any downloads that satisfy the requirement entrypoints
>> > (from nbconvert->jupyter)
>> > No distributions at all found for entrypoints (from nbconvert->jupyter)
>> > Storing complete log in /root/.pip/pip.log
>> > bilbo at ecfm:~$ Downloading/unpacking entrypoints (from
>> > nbconvert->jupyter)
>> > -bash: error sintáctico cerca del elemento inesperado `('
>> > bilbo at ecfm:~$
>> >
>> >
>> > Thanks,
>> >
>> > bye
>> > _______________________________________________
>> > IPython-dev mailing list
>> > IPython-dev at scipy.org
>> > https://mail.scipy.org/mailman/listinfo/ipython-dev
>>
>> --
>> Brian E. Granger
>> Associate Professor of Physics and Data Science
>> Cal Poly State University, San Luis Obispo
>> @ellisonbg on Twitter and GitHub
>> bgranger at calpoly.edu and ellisonbg at gmail.com
>>
>>
>> _______________________________________________
>> IPython-dev mailing list
>> IPython-dev at scipy.org
>> https://mail.scipy.org/mailman/listinfo/ipython-dev
>>
>
>
>



More information about the IPython-dev mailing list