[IPython-dev] How to use ipykernel for replace deprecated modules?

Alan alanwilter at gmail.com
Wed Aug 3 12:37:38 EDT 2016


Many thanks Thomas!

It was my mess of mixing Fink with Pip. All fixed now.

Cheers,

Alan

On 3 August 2016 at 17:14, Thomas Kluyver <takowl at gmail.com> wrote:

> Hi Alan,
>
> I think an upgrade has gone wrong or something, because there are files in
> that traceback that shouldn't exist in IPython 5.0. I'd try removing
> ipython entirely and installing it again.
>
> Thomas
>
> On 3 August 2016 at 17:05, Alan <alanwilter at gmail.com> wrote:
>
>> I am using
>>
>> Server Information:
>>
>> You are using Jupyter notebook.
>>
>> The version of the notebook server is *4.2.2* and is running on:
>>
>> Python 3.5.2 (default, Jun 30 2016, 18:10:25)
>> [GCC 4.2.1 Compatible Apple LLVM 7.0.2 (clang-700.1.81)]
>>
>> Current Kernel Information:
>>
>> Python 3.5.2 (default, Jun 30 2016, 18:10:25)
>> Type "copyright", "credits" or "license" for more information.
>>
>> IPython 5.0.0 -- An enhanced Interactive Python.
>> ?         -> Introduction and overview of IPython's features.
>> %quickref -> Quick reference.
>> help      -> Python's own help system.
>> object?   -> Details about 'object', use 'object??' for extra details.
>>
>>
>> My basic problem as follow:
>>
>> from IPython.html.widgets import *
>> from IPython.display import display
>>
>> /sw/lib/python3.5/site-packages/IPython/utils/traitlets.py:5:
>> UserWarning: IPython.utils.traitlets has moved to a top-level traitlets
>> package.
>>   warn("IPython.utils.traitlets has moved to a top-level traitlets
>> package.")
>> /sw/lib/python3.5/site-packages/IPython/kernel/__init__.py:13:
>> ShimWarning: The `IPython.kernel` package has been deprecated. You should
>> import from ipykernel or jupyter_client instead.
>>   "You should import from ipykernel or jupyter_client instead.",
>> ShimWarning)
>>
>> ---------------------------------------------------------------------------
>> ImportError                               Traceback (most recent call
>> last)
>> <ipython-input-3-d4f1ddbc099e> in <module>()
>> ----> 1 from IPython.html.widgets import *
>>       2 from IPython.display import display
>>
>> /sw/lib/python3.5/site-packages/IPython/html/widgets/__init__.py in
>> <module>()
>>       3 from .trait_types import Color
>>       4
>> ----> 5 from .widget_bool import Checkbox, ToggleButton
>>       6 from .widget_button import Button
>>       7 from .widget_box import Box, FlexBox, HBox, VBox
>>
>> /sw/lib/python3.5/site-packages/IPython/html/widgets/widget_bool.py in
>> <module>()
>>      16 from .widget import DOMWidget, register
>>      17 from IPython.utils.traitlets import Unicode, Bool, CaselessStrEnum
>> ---> 18 from IPython.utils.warn import DeprecatedClass
>>      19
>>      20
>> #-----------------------------------------------------------------------------
>>
>> ImportError: cannot import name 'DeprecatedClass'
>>
>> Many thanks in advance,
>>
>> Alan
>> --
>> Alan Wilter SOUSA da SILVA, DSc
>> Senior Bioinformatician, UniProt
>> European Bioinformatics Institute (EMBL-EBI)
>> European Molecular Biology Laboratory
>> Wellcome Trust Genome Campus
>> Hinxton
>> Cambridge CB10 1SD
>> United Kingdom
>> Tel: +44 (0)1223 494588
>>
>> _______________________________________________
>> IPython-dev mailing list
>> IPython-dev at scipy.org
>> https://mail.scipy.org/mailman/listinfo/ipython-dev
>>
>>
>
> _______________________________________________
> IPython-dev mailing list
> IPython-dev at scipy.org
> https://mail.scipy.org/mailman/listinfo/ipython-dev
>
>


-- 
Alan Wilter SOUSA da SILVA, DSc
Senior Bioinformatician, UniProt
European Bioinformatics Institute (EMBL-EBI)
European Molecular Biology Laboratory
Wellcome Trust Genome Campus
Hinxton
Cambridge CB10 1SD
United Kingdom
Tel: +44 (0)1223 494588
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/ipython-dev/attachments/20160803/7525a67e/attachment.html>


More information about the IPython-dev mailing list