<br><br><div class="gmail_quote">On Thu, Jan 27, 2011 at 3:28 PM, Warren Weckesser <span dir="ltr"><<a href="mailto:warren.weckesser@enthought.com">warren.weckesser@enthought.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">

<br><br><div class="gmail_quote"><div class="im">On Thu, Jan 27, 2011 at 3:18 PM, Fernando Perez <span dir="ltr"><<a href="http://fperez.net" target="_blank">fperez.net</a>@<a href="http://gmail.com" target="_blank">gmail.com</a>></span> wrote:<br>

<blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">
On Wed, Jan 26, 2011 at 7:12 PM, Brian Granger <<a href="mailto:ellisonbg@gmail.com" target="_blank">ellisonbg@gmail.com</a>> wrote:<br>
> I mean require 2.0.10?<br>
<br>
Aha, thanks.   Yes, my problem was a too-old pyzmq.<br>
<br>
It's OK that we have a minimal version requirement, but what we should<br>
do is catch the problem and report with a useful message.  A 'minimal<br>
pyzmq version required for IPython is 2.0.X' message would have let me<br>
know what's going on by myself, where as I was misled into thinking<br>
the problem could have been elsewhere.<br>
<br>
Given Mark's sleuthing on the state of distros, I have no problem with<br>
requiring 2.0.10.  I don't think EPD is officially shipping any pyzmq<br>
yet, are they?</blockquote></div><div><br><br>The current EPD (6.2) has pyzmq 2.0.8.  EPD 6.3 (due to be released in a couple weeks) will have 2.0.10.<br><font color="#888888">
<br></font></div></div></blockquote><div><br>Whoops... increment the EPD version numbers by 0.1:  The current EPD (6.3) has pyzmq 2.0.8.  EPD 6.4 (due to be released in a couple weeks) will have 2.0.10.<br><br><br></div>

<blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;"><div class="gmail_quote"><div><font color="#888888">
Warren<br><br> </font></div><div class="im"><blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">  We could always be super-nice and use the slow<br>


fallback on 2.0.9, but I'm OK not even doing that until we hear an<br>
actual complaint of a usage scenario where 2.0.10 is an unsuitable<br>
burden for a user.<br>
<br>
I'll proceed to update my pyzmq now, thanks for the info!<br>
<br>
Cheers,<br>
<br>
f<br>
_______________________________________________<br>
IPython-dev mailing list<br>
<a href="mailto:IPython-dev@scipy.org" target="_blank">IPython-dev@scipy.org</a><br>
<a href="http://mail.scipy.org/mailman/listinfo/ipython-dev" target="_blank">http://mail.scipy.org/mailman/listinfo/ipython-dev</a><br>
</blockquote></div></div><br>
</blockquote></div><br>