I haven't been able to run the Qt console on MS Windows XP since ipython 0.11 was released (.rc versions worked). I decided to clean things up and retry today. <div><br></div><div>I did an install of python2.7 from <a href="http://python.org">python.org</a>. Next, easy_install <path-to-ipython0.11.zip>.  That gave a few warnings about "no previously included files ..." a few times, but it finished without error. When I tried to run either of these ways:</div>
<div> 1.  C:\Python27\Scripts\ipython-qtconsole.exe  or</div><div> 2.  C:\Python27\Python.exe C:\Python27\Scripts\ipython-qtconsole-script</div><div><br></div><div>I got 1. nothing, 2. complaint about missing pygments.styles.</div>
<div>Did easy_install pygments.</div><div><br></div><div>Then 2. complaint about missing pyzmq >= 2.1.4.</div><div>Did easy_install pyzmq, which installed version 2.1.10.</div><div><br></div><div>Then 2. complaint saying it "requires pyzmq >= 2.1.4, but you have 2.1.10". Math doesn't work out.</div>
<div>Then 1. nothing.<br>I tried an .msi install of version 2.1.4 of pyzmq, but still got the complaint about 2.1.10 not >= 2.1.4, so I suppose I have to try to figure out how to uninstall 2.1.10.</div><div><br></div><div>
Am I making some mistakes here?</div><div><br></div>