[IronPython] Problems with tutorials

Martin Maly Martin.Maly at microsoft.com
Mon Dec 12 18:51:49 CET 2005


Believe it or not, this problem is actually caused by the missing [STAThread] attribute on the IronPythonConsole Main. Good to know this :) Seems that when I remove it, I caused problems for more people than I helped. As I said in my previous email to Jacques, I am going to fix this for the next release. If there is no beter way to do that, I am going to put the [STAThread] attribute back. It is also the workaround for the time being.

Thanks for the bug report, Keith!

Martin

-----Original Message-----
From: users-bounces at lists.ironpython.com [mailto:users-bounces at lists.ironpython.com] On Behalf Of Keith J. Farmer
Sent: Monday, December 12, 2005 1:51 AM
To: Discussion of IronPython
Subject: [IronPython] Problems with tutorials

Encountering a variety of problems with the agents tutorial:
a = AgentServerClass() -> should not have () ?
a.Load("Merlin.acs") -> throws bad args exception for the Load() method.
Doesn't change if I use C:\WINDOWS\msagent\chars\merlin.acs, which exists on my machine.  Also doesn't work if I call AgentServerClass.Load("merlin.acs").
NB:  I'm using x64.
With the Avalon tutorial, I get "can't set arbitrary attributes on built-in type System.Windows.Window" when I try w.Text = "My Avalon Application".  Trying to retrieve w.Text gives no-such-attribute error.
w.Title does exist, however.
w.Content.TextContent should be w.Content.Text, I think.
w.Content.PersistentAnimations doesn't exist, and I don't see any likely rename.
-----
Keith J. Farmer // kfarmer at thuban.org

_______________________________________________
users mailing list
users at lists.ironpython.com
http://lists.ironpython.com/listinfo.cgi/users-ironpython.com



More information about the Ironpython-users mailing list