[IronPython] MapPoint COM object?

Vincent vincent at visualtrans.de
Mon Apr 17 09:41:47 CEST 2006

Hi Gardner

I also noticed this when going through the COM interop tutorial the other

You could try using
which worked for me.

(FYI, a bug has been logged in MS bugdb...)

Vincent Wehren


	From: users-bounces at lists.ironpython.com
[mailto:users-bounces at lists.ironpython.com] On Behalf Of Gardner Pomper
	Sent: Monday, April 17, 2006 12:34 AM
	To: Discussion of IronPython
	Cc: IronPython List
	Subject: [IronPython] MapPoint COM object?
	I am trying to manipulate mappoint from an IronPython script. I
tried to do the COM integration I found in the Tutorial, but it failed. I
have copied what I did into this email. Can someone take a look and tell me
what I should have done? 
	- Gardner
	C:\Program Files\Microsoft MapPoint>tlbimp mpna82.tlb
	Microsoft (R) .NET Framework Type Library to Assembly Converter
	Copyright (C) Microsoft Corporation.  All rights reserved. 
	Type library imported to MapPoint.dll
	C:\Program Files\Microsoft MapPoint>\IronPython\IronPythonConsole
	IronPython 1.0.2280 (Beta) on .NET 2.0.50727.42
	Copyright (c) Microsoft Corporation. All rights reserved. 
	>>> import clr
	>>> clr.AddReferenceToFile('MapPoint.dll')
	Traceback (most recent call last):
	  File , line 0, in input##5
	  File , line 0, in AddReferenceToFile##6
	RuntimeError: Could not add reference to assembly MapPoint.dll

More information about the Ironpython-users mailing list