[IronPython] IronPython & Python 2.5

Ryan Dawson rdawson at exchange.microsoft.com
Tue Aug 29 01:30:50 CEST 2006


Recent builds of IronPython (starting in beta 8 I believe) have included some initial support for CPython 2.5 language features (with statement, __missing__, etc) but this support is neither complete nor enabled by default (you must specify the -X:Python25 to enable the support we have).

That said I have not tried the 2.5 libs, but would expect some issues to the degree that the updated libs use new 2.5 language features.

Thanks,
        -Ryan

-----Original Message-----
From: users-bounces at lists.ironpython.com [mailto:users-bounces at lists.ironpython.com] On Behalf Of Kevin Bjorke
Sent: Monday, August 28, 2006 2:44 PM
To: Discussion of IronPython
Subject: [IronPython] IronPython & Python 2.5

I've been using libs from CPython 2.4.2 -- anything I should beware
before moving to the new CPython 2.5 libs?

Thanks
kb
-----------------------------------------------------------------------------------
This email message is for the sole use of the intended recipient(s) and may contain
confidential information.  Any unauthorized review, use, disclosure or distribution
is prohibited.  If you are not the intended recipient, please contact the sender by
reply email and destroy all copies of the original message.
-----------------------------------------------------------------------------------
_______________________________________________
users mailing list
users at lists.ironpython.com
http://lists.ironpython.com/listinfo.cgi/users-ironpython.com



More information about the Ironpython-users mailing list