[IronPython] Differences in resource usage between stand alone and ClickOnce > Same code base

M. David Peterson xmlhacker at gmail.com
Fri Mar 16 01:00:17 CET 2007

Forgot to mention,

>From the commandline,

>>> from cherrypyserver import run,shutdown
>>> run()

to start the server which is then accessible @ http://localhost:9999/

On 3/15/07, M. David Peterson <xmlhacker at gmail.com> wrote:
> In the ongoing development of the Xameleon (merge between
> Amplee/AtomicXML) application Sylvain and I have been running into various
> hurdles, none of which have been insurmountable, but the most recent of
> which I am having trouble attempting to understand the problem.
> Background: A few days back we discovered that attempting to startup and
> run Amplee via CherryPy we were reaching upwards of 150megs just to start up
> the server.  After a bit of digging we discovered that saving the assemblies
> (-X:SaveAssemblies) during the first run, and then restarting the app
> dropped the resource usage meter from 150 to below 50 megs, something that
> was definitely within reason.
> That said, assuming that the same resources would be consumed for both a
> stand alone implementation, as well as a ClickOnce implementation (both
> ClickOnce and standalone were both consuming ~150megs before saving the
> assemblies), I was surprised to discover recently that there is ~45meg
> increase in the ClickOnce implementation over the standalone.
> You can access the standalone files @
> http://extf.googlecode.com/files/Xameleon.WebApp.0.1.15.zip and the
> ClickOnce app @ http://xameleon.org/Personal.Web.Platform/ClickOnce/
> These both come from the exact same code base/project @ http://extf.googlecode.com/svn/trunk/Xameleon.WebApp/
> and I've verified that the same compiled .exe modules exist in both
> implementations, so as far as I can tell, this isn't a situation where I
> simply forgot to include some of the compiled Python modules in the
> ClickOnce implementation, accounting for the difference in resource usage as
> a result.
> Any ideas as to what might be the issue, and how to solve it?
> Thanks in advance!
> --
> /M:D
> M. David Peterson
> http://mdavid.name | http://www.oreillynet.com/pub/au/2354 |
> http://dev.aol.com/blog/3155


M. David Peterson
http://mdavid.name | http://www.oreillynet.com/pub/au/2354 |
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/ironpython-users/attachments/20070315/95cd86be/attachment.html>

More information about the Ironpython-users mailing list