[IronPython] Having problems in connecting to an Oracle Database using last version of ODP.NET

Vizcayno Tamparantan vizcaynot at gmail.com
Fri Sep 14 03:22:47 CEST 2007

I recently installed Oracle 11g ODAC Beta in my Win XP SP2
machine and began to type next code under "IronPython console: IronPython
2.0A4 (2.0.10904.02) on .NET 2.0.50727.42":

import clr
import System
from System.Data import DataSet
import Oracle.DataAccess

Just after last instruction, next error is issued:
Traceback (most recent call last):
  File , line 0, in ##172
  File , line 0, in _stub_##2
  File c:\os\ipy\src\Oracle.py, line 8, in Initialize
  File , line 0, in _stub_##176
AttributeError: 'module' object has no attribute 'OracleConnection'

In C# I made similar operations including data recovery without problems, I
show you the code where the first line shows the way I compiled:
// csc oracle.cs/r:C:\oracle\product\11.1.0\client_1\odp.net\bin\2.x\Oracle.DataAccess.dll
using System;
using System.Data;
using Oracle.DataAccess.Client;
public class uracle
 public static void Main()
        OracleConnection con = new OracleConnection();
        con.ConnectionString = "User ID=xxx;Password=yyy;Data Source=zzz";
            Console.WriteLine("Conn opened.");
            string cmdQuery = "SELECT EMPLOYEE_ID FROM PERSON";
            OracleCommand cmd = new OracleCommand(cmdQuery);
            cmd.Connection = con;
            cmd.CommandType = CommandType.Text;
            OracleDataReader reader = cmd.ExecuteReader();
            while (reader.Read())
        catch (Exception ex)

What do you think is happening? what is wrong with my ipy code?
Thanks for your attention and HELP!!!!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/ironpython-users/attachments/20070913/e0bda0df/attachment.html>

More information about the Ironpython-users mailing list