[IronPython] Why can't I use 'import os' in Ironpython Studio? It always says "No module named os".

Michael Foord fuzzyman at voidspace.org.uk
Tue Dec 23 12:43:48 CET 2008

Jankins wrote:
> Hi,
> I have been using Ironpython studio for about two days. And I found a 
> strange problem. I can't use "import os" or  " import copy" (until now 
> I just found these two) in my program, because when I debug my 
> program, it says "No module named os". But I can use "import sys" , 
> "import time" or "import math". I don't know why.
> I reinstall Ironpython Studio, but it still doesn't work. And I tried 
> to find the lib location used by Iropython studio, but I can't find it.
> Please help me about it. This problem really drives me crazy.

Mainly because IronPython Studio, despite being a very impressive proof 
of concept, is a steaming heap of dung for actually developing with.

If you need the winforms / wpf designer then I recommend Visual Studio 
(Express) generating C# that you then use from IronPython. For 
developing Python projects you can use a real Python IDE like Wing, 
Komodo or SPE - or even a text editor like Vim (*ouch*) or Emacs. Any of 
these will suit you much better than IronPython Studio I'm afraid.

All the best,

Michael Foord

> Thanks so much.
> Jankins
> ------------------------------------------------------------------------
> _______________________________________________
> Users mailing list
> Users at lists.ironpython.com
> http://lists.ironpython.com/listinfo.cgi/users-ironpython.com


More information about the Ironpython-users mailing list