[IronPython] error when 'import os'

Curt Hagenlocher curt at hagenlocher.org
Wed May 14 14:00:45 CEST 2008

We're not distributing the standard Python library with IronPython right
now, so to load os.py, you'd need a copy from the standard distribution or
download Seo's IronPython Community Edition from

"nt" is a different matter because it's built into the IronPython.dll, so
I'm not sure why you might be getting the same error from "nt".  On a plain
vanilla "installation" of 1.1.1 that I just recently downloaded from
CodePlex, I get the following:
PS F:\IronPython-1.1.1> .\ipy.exe
IronPython 1.1.1 (1.1.1) on .NET 2.0.50727.1434
Copyright (c) Microsoft Corporation. All rights reserved.
>>> import nt

You get the same error as in the example below?

On Wed, May 14, 2008 at 4:54 AM, Ben Aurel <ben.aurel at gmail.com> wrote:

> hi
> I've a simple script that involves the creation of a file. The script
> doesn't run because it can't import the 'os' module. It's the same message
> when I try to import it at the interactive shell:
> ---
> IronPython 1.1.1 (1.1.1) on .NET 2.0.50727.42
> Copyright (c) Microsoft Corporation. All rights reserved.
> >>> import os
> Traceback (most recent call last):
> ImportError: No module named os
> ---
> replacing 'os' with 'nt' gives me the same error.
> Any ideas what I'm doing wrong here?
> thanks a lot
> ben
> _______________________________________________
> Users mailing list
> Users at lists.ironpython.com
> http://lists.ironpython.com/listinfo.cgi/users-ironpython.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/ironpython-users/attachments/20080514/08f0f16c/attachment.html>

More information about the Ironpython-users mailing list