[IronPython] ActiveX STA Issue in compiled Winforms EXE

Davy Mitchell daftspaniel at gmail.com
Sat Nov 8 15:19:22 CET 2008


Hi Michael

>Are you doing this from a separate thread?

No.

It's a couple of modules deep from the 'main' script. Was going to try
a single py file to repro.

> I assume it works fine when run uncompiled?

Yep, runs great.
Cheers,
Davy


On 11/8/08, Michael <fuzzyman at gmail.com> wrote:
> Are you doing this from a separate thread? I assume it works fine when
> run uncompiled?
>
>
> Michael
>
> http://www.ironpythoninaction.com
>
> On 8 Nov 2008, at 12:10, "Davy Mitchell" <daftspaniel at gmail.com> wrote:
>
>> IPY 2.0 RC1
>>
>>
>> ActiveX Issue in a pyc compiled Winforms EXE which uses the
>> WebBrowser control.
>>
>> Unhandled Exception: System.Threading.ThreadStateException: ActiveX
>> control '8856f961-340a-11d0-a96b-00c04fd705a2' cannot be
>> instantiated because the current thread is not in a single-threaded
>> apartment.
>>    at System.Windows.Forms.WebBrowserBase..ctor(String clsidString)
>>    at System.Windows.Forms.WebBrowser..ctor()
>>    at _stub_$643##332(Closure , CallSite , CodeContext , Object )
>>    at Microsoft.Scripting.Actions.MatchCaller.Call2[T0,T1,TRet]
>> (Func`4 target, C
>>
>> Help!! :-)
>>
>> Any thoughts before I delve further into this?
>>
>> Thanks
>> Davy Mitchell
>> _______________________________________________
>> Users mailing list
>> Users at lists.ironpython.com
>> http://lists.ironpython.com/listinfo.cgi/users-ironpython.com
> _______________________________________________
> Users mailing list
> Users at lists.ironpython.com
> http://lists.ironpython.com/listinfo.cgi/users-ironpython.com
>



More information about the Ironpython-users mailing list